Seleccionar página

Desactualizar un plugin de WordPress es algo que no había tenido que hacer hasta ahora.

Y todo ha sido porque he empezado a tener conflictos entre dos plugins.

Así que he seguido mis propios consejos y me he puesto a buscar ayuda en foro de soporte del plugin.

En este caso recomendaban utilizar la versión anterior del plugin que daba conflicto, porque los cambios estaban en la parte de presentación y no en base de datos.

He encontrado dos soluciones para desactualizar un plugin, y las dos funcionan muy bien.

Un Plugin para desactualizar un plugin

Aunque he probado las dos opciones me quedo con el plugin porque es muy sencilla.

Wp Rollback Plugin

Una vez instalado y activado, si te vas al listado de plugins de WordPress, encontrarás un nuevo enlace con el nombre Rollback debajo del nombre de cada plugin.

Wp Rollback Option

Si haces clic en el enlace, te mostrará un listado con las versiones del plugin, para que puedas elegir la que necesitas.

También te indica cual es la versión que tienes activa en este momento.

Wp Rollback Select Version

Una vez seleccionada la versión haces clic en el botón Rollback y verás el siguiente aviso que recomiendo leer siempre para comprobar que todo está ok.

Wp Rollback Aviso Cambio

Una vez terminado el proceso, veremos el siguiente mensaje y sabremos que todo ha terminado bien.

Wp Rollback Aviso Cambio Finalizado

Ya sólo queda activar el plugin y comprobar si se soluciona el problema.

Desactualizar un plugin de forma manual

Para esta solución necesitas tener algo de conocimiento de la estructura de carpetas de WordPress y saber utilizar ftp con tu servidor, no es que sea muy complicado pero en comparación me ha parecido más sencilla la otra opción.

De todas formas vamos a ver como sería.

Necesitas tener acceso por ftp al directorio de archivos donde se encuentra el plugin.

/wp-content/plugins/

No olvides hacer una copia de seguridad igual que en el caso anterior.

También necesitarás localizar la versión anterior del plugin.

Debes hacer clic en Advanced View en la página del plugin del repositorio de WordPress.

Wordpress Repository Plugin Advanced View

Una vez en la vista avanzada, en la parte del fondo, encontrarás el listado de versiones, y el botón para descargar la que necesitas.

Wordpress Repository Plugin Versions

Y ya lo tienes todo, para reemplazar el plugin tienes que seguir estos pasos:

  1. Descarga la versión antigua que necesitas del repositorio de plugins de WordPress.
  2. Desactivar el plugin.
  3. Acceder al servidor por FTP o SSH.
  4. Subir la versión del plugin anterior a wp-content/plugins/. (Debes sobreescribir la versión que hay en el servidor.)
  5. Activar el plugin

Y hemos terminado, tienes instalada y funcionando la versión anterior del plugin.

Conclusiones

Mi agradecimiento a la comunidad, siempre digo que es lo mejor de WordPress.

El problema de incompatibilidad debería ser temporal, hay que hacer un seguimiento del problema para saber cuando está resuelto y volver a las versiones recientes.

Si el problema no se resuelve es hora de cambiar de plugin. Un plugin desactualizado durante mucho tiempo puede suponer una brecha de seguridad.

 

¡Hasta Pronto!

 

Lux Your business &

Love Your Website!